۱۳۸۹ مهر ۷, چهارشنبه

ساعت چنده؟

مرد جوان: ببخشید آقا میشه بگین ساعت چنده؟پیرمرد: معلومه که نه!- چرا آقا... مگه چی ازتون کم میشه اگه به من ساعت رو بگین؟!-

یه چیزایی کم میشه و اگه به تو ساعت رو بگم به ضررم میشه- ولی آقا آخه میشه به من بگین چه جوری؟!-

ببین اگه من به تو ساعت رو بگم مسلما تو از من تشکر می کنی و شاید فردا دوباره از من ساعت رو بپرسی نه؟-

خوب... آره امکان داره- امکانش هم هست که ما دو سه بار یا بیش تر باز هم همدیگه رو ملاقات کنیم و تو از من اسم و آدرسم رو هم بپرسی- خوب... آره این هم امکان داره-

یه روزی شاید بیای خونه من و بگی داشتم از این دور و ورا رد می شدم گفتم یه سری به شما بزنم و منم بهت تعارف کنم بیای تو تا یه چایی با هم بخوریم و بعد این تعارف و ادبی که من به جا آوردم باعث بشه که تو دوباره بیای دیدن من و در اون زمانه که میگی به به چه چایی خوش طعمی و بپرسی که کی اونو درست کرده- آره ممکنه...-


بعدش من به تو میگم که دخترم چایی رو درست کرده و در اون زمان هست که باید دختر خوشگل و جوونم رو به تو معرفی کنم و تو هم از دختر من خوشت بیاد- لبخندی بر لب مرد جوان نشست-


در این زمان هست که تو هی می خوای بیای و دختر منو ملاقات کنی و ازش می خوای باهات قرار بذاره و یا این که با هم برین سینما!- مرد جوان از تجسم این موضوع باز هم لبخند زد-


دختر من هم کم کم به تو علاقمند میشه و همیشه چشم انتظارته که بیای و پس از ملاقات های مکرر تو هم عاشقش میشی و ازش درخواست می کنی که باهات ازدواج کنه- مرد جوان همچنان نیش لبخندش بازتر شد-


یه روزی هر دوتاتون میاین پیش من و به عشقتون اعتراف می کنین و از من واسه عروسیتون اجازه می خواین- اوه بله... حتما و تبسمی عاشقانه بر لبانش نشست-


پیرمرد با عصبانیت به مرد جوان گفت: من هیچ وقت اجازه نمیدم که دختر دسته گلم با آدمی مثل تو که حتی یه ساعت مچی هم نداره ازدواج کنه... می فهمی؟!و پیرمرد با عصبانیت از مرد جوان دور شد ...

IBSng 1.24 database backup

تهیه پشتیبان از دیتابیس IBSng و باز گرداندن آن:
su  - postgres
Backup >>        Pg_dump   IBSng   >    IBSng.bak
Restore >>       Psql    IBSng     <     IBSng.bak
Or
Restore>>        psql     -d   IBSng    -f    IBSng.bak
logout
 
بر روی سیستمی که می خواهید دیتابیس را برگردانید در زمان نصب IBSng مرحله سوم یعنی Import Tables and Continue را انجام ندهید و گزینه continue را انتخاب کنید.
یا اگر IBSng از قبل نصب شده می بایست دیتابیس رو پاک و مجدد ایجاد کنید و بعد از آن پشتیبان را برگردانید.
dropdb IBSng
createdb IBSng
لیست دیتابیس ها را می توانید با دستور زیر مشاهده کنید :
psql -l

۱۳۸۹ مهر ۵, دوشنبه

آرامش

یه پسر و دختر کوچولو داشتن با هم بازی میکردن. پسر کوچولو یه سری تیله داشت و دختر کوچولو چندتایی شیرینی با خودش داشت. پسر کوچولو به دختر کوچولو گفت من همه تیله هامو بهت میدم؛ تو همه شیرینیاتو به من بده. دختر کوچولو قبول کرد.
پسر کوچولو بزرگترین و قشنگترین تیله رو یواشکی واسه خودش گذاشت کنار و بقیه رو به دختر کوچولو داد. اما دختر کوچولو همون جوری که قول داده بود تمام شیرینیاشو به پسرک داد.
همون شب دختر کوچولو با ارامش تمام خوابیدو خوابش برد. ولی پسر کوچولو نمی تونست بخوابه چون به این فکر می کرد که همونطوری خودش بهترین تیله اشو یواشکی پنهان کرده شاید دختر کوچولو هم مثل اون یه خورده از شیرینیهاشو قایم کرده و همه شیرینی ها رو بهش نداده

نتیجه اخلاقی داستان:
  • عذاب وجدان هميشه مال كسي است كه صادق نيست
  • آرامش مال كسي است كه صادق است
  • لذت دنيا مال كسي نيست كه با آدم صادق زندگي مي كند
  • آرامش دنيا مال اون كسي است كه با وجدان صادق زندگي ميكند

۱۳۸۹ مهر ۱, پنجشنبه

خوشبختی

يک تاجر آمريکايي نزديک يک روستاي مکزيکي ايستاده بود. در همان موقع يک قايق کوچک ماهيگيري رد شد که داخلش چند تا ماهي بود.
از ماهيگير پرسيد: چقدر طول کشيد تا اين چند تا ماهي رو گرفتي؟
ماهيگير: مدت خيلي کمي.
تاجر: پس چرا بيشتر صبر نکردي تا بيشتر ماهي گيرت بياد؟
ماهيگير: چون همين تعداد براي سير کردن خانواده ام کافي است.
 تاجر: اما بقيه وقتت رو چيکار مي کني؟
ماهيگير: تا دير وقت مي خوابم, يه کم ماهي گيري مي کنم, با بچه ها بازي ميکنم بعد ميرم توي دهکده و با دوستان شروع مي کنيم به گيتار زدن. خلاصه مشغوليم به اين نوع زندگي.
 تاجر: من تو هاروارد درس خوندم و مي تونم کمکت کنم. تو بايد بيشتر ماهي گيري کني.
اون وقت مي توني با پولش قايق بزرگتري بخري و با درآمد اون چند تا قايق ديگر هم بعدا اضافه ميکني. اون وقت يه عالمه قايق براي ماهيگيري داري.
ماهيگير: خوب, بعدش چي؟
تاجر: به جاي اينکه ماهي ها رو به واسطه بفروشي اونا رو مستقيــما به مشتري ها ميدي و براي خودت کارو بار درست مي کني... بعدش کارخونه راه مي اندازي و به توليداتش نظارت ميکني... اين دهکده کوچک رو هم ترک مي کني و مي روي مکــــزيکوسيتي! بعد از اون هم لوس آنجلس! و از اونجا هم نيويورک... اونجاست که دست به کارهاي مهم تري مي زني...
 ماهيگير:اين کار چقدر طول مي کشه؟
تاجر: پانزده تا بيست سال.
ماهيگير: اما بعدش چي آقا؟
تاجر: بهترين قسمت همينه,در يک موقعيت مناسب که گير اومد ميري و سهام شرکت رو به قيمت خيلي بالا مي فروشي! اين کار ميليون ها دلار برات عايدي داره.
ماهيگير: ميليون ها دلار! خوب بعدش چي؟
تاجر: اون وقت بازنشسته مي شي! مي ري يه دهکــده ي ساحلي کوچيک! جايي که مي توني تا دير وقت بخوابي! يه کم ماهيگيري کني, با بچه هات بازي کني! بري دهکده و تا ديروقت با دوستات گيتار بزني و خوش بگذروني

۱۳۸۹ شهریور ۳۰, سه‌شنبه

فرق دیوانه و احمق

مردی در هنگام رانندگی، درست جلوی حياط يک تيمارستان پنچر شد و مجبورشد همانجا به تعويض لاستيک بپردازد.
هنگامی که سرگرم اين کار بود، ماشين ديگری به سرعت ازروی مهره های چرخ که در کنار ماشين بودند گذشت و آنها را به درون جوی آب انداخت و آب مهره ها را برد.
مرد حيران مانده بود که چکار کند.
تصميم گرفت که ماشينش را همانجارها کند و برای خريد مهره چرخ برود.
در اين حين، يکی از ديوانه ها که از پشت نرده های حياط تيمارستان نظاره گر اين ماجرا بود، او را صدا زد و گفت:
از ٣ چرخ ديگر ماشين، از هر کدام يک مهره بازکن و اين لاستيک را با ٣ مهره ببند و برو تا به تعميرگاه برسی.

آن مرد اول توجهی به اين حرف نکرد ولی بعد که با خودش فکر کرد ديد راست می گويد و بهتر است همين کار را بکند.
پس به راهنمايی او عمل کرد و لاستيک زاپاس را بست.
هنگامی که خواست حرکت کند رو به آن ديوانه کرد و گفت: «خيلی فکر جالب و هوشمندانه ای داشتی.
پس چرا توی تيمارستان انداختنت؟
ديوانه لبخندی زد و گفت: من اينجام چون ديوانه ام. ولی احمق که نيستم!!ا

۱۳۸۹ شهریور ۲۹, دوشنبه

شادیهایمان را قسمت کنیم

زن جوانی در سالن فرودگاه منتظر پروازش بود. چون هنوز چند ساعت به پروازش باقي مانده بود، تصميم گرفت براي گذراندن وقت کتابي خريداري کند. او يک بسته بيسکوئيت نيز خريد و بر روي يک صندلي نشست و در آرامش شروع به خواندن کتاب کرد.

مردي در کنارش نشسته بود و داشت روزنامه مي‌خواند. وقتي که او نخستين بيسکوئيت را به دهان گذاشت، متوجه شد که مرد هم يک بيسکوئيت برداشت و خورد. او خيلي عصباني شد ولي چيزي نگفت. پيش خود فکر کرد : بهتر است ناراحت نشوم. شايد اشتباه کرده باشد.

ولي اين ماجرا تکرار شد. هر بار که او يک بيسکوئيت برمي‌داشت، آن مرد هم همين کار را مي‌کرد. اينکار او را حسابي عصباني کرده بود ولي نمي‌خواست واکنشي نشان دهد. وقتي که تنها يک بيسکوئيت باقي مانده بود، پيش خود فکر کرد : حالا ببينم اين مرد بي‌ادب چکار خواهد کرد؟ مرد آخرين بيسکوئيت را نصف کرد و نصفش ديگرش را خورد. اين ديگه خيلي پرروئي مي‌خواست! زن جوان حسابي عصباني شده بود.

در اين هنگام بلندگوي فرودگاه اعلام کرد که زمان سوار شدن به هواپيماست. آن زن کتابش را بست، چيزهايش را جمع و جور کرد و با نگاه تندي که به مرد انداخت از آنجا دور شد و به سمت دروازه اعلام شده رفت. وقتي داخل هواپيما روي صندلي‌اش نشست، دستش را داخل ساکش کرد تا عينکش را داخل ساک قرار دهد و ناگهان با کمال تعجب ديد که جعبه بيسکوئيتش آنجاست، باز نشده و دست نخورده!

خيلي شرمنده شد! از خودش بدش آمد ... يادش رفته بود که بيسکوئيتي که خريده بود را داخل ساکش گذاشته بود. آن مرد بيسکوئيت‌هايش را با او تقسيم کرده بود، بدون آن که عصباني و برآشفته شده باشد.

۱۳۸۹ شهریور ۲۶, جمعه

گل سرخي براي محبوبم

" جان بلانکارد " از روي نيمکت برخاست لباس ارتشي اش را مرتب کرد و به تماشاي انبوه مردم که راه خود را از ميان ايستگاه بزرگ مرکزي پيش مي گرفتند مشغول شد .

او به دنبال دختري مي گشت که چهره او را هرگز نديده بود اما قلبش را مي شناخت دختري با يک گل سرخ .

از سيزده ماه پيش دلبستگي‌اش به او آغاز شده بود.از يک کتابخانه مرکزي در فلوريدا, با برداشتن کتابي از قفسه ناگهان خود را شيفته و مسحور يافته بود,اما نه شيفته کلمات کتاب بلکه شيفته يادداشتهايي با مداد, که در حاشيه صفحات آن به چشم مي‌خورد . دست خطي لطيف که بازتابي از ذهني هوشيار و درون بين و باطني ژرف داشت در صفحه اول " جان" توانست نام صاحب کتاب را بيابد:
"دوشيزه هاليس مي نل" .
 با اندکي جست و جو و صرف وقت او توانست نشاني دوشيزه هاليس را پيدا کند." جان " براي او نامه اي نوشت و ضمن معرفي خود از او درخواست کرد که به نامه نگاري با او بپردازد . روز بعد جان سوار کشتي شد تا براي خدمت در جنگ جهاني دوم عازم شود .در طول يکسال و يک ماه پس از آن , آن دو به تدريج با مکاتبه و نامه نگاري به شناخت يکديگر پرداختند .

هر نامه همچون دانه اي بود که بر خاک قلبي حاصلخيز فرو مي افتاد و به تدريج عشق شروع به جوانه زدن کرد .

" جان " درخواست عکس کرد ولي با مخالفت " ميس هاليس " روبه رو شد . به نظر هاليس اگر " جان " قلبا به او توجه داشت ديگر شکل ظاهري اش نمي توانست براي او چندان با اهميت باشد . ولي سرانجام روز بازگشت " جان " فرارسيد آن ها قرار نخستين ملاقات خود را گذاشتند : 7 بعد الظهر در ايستگاه مرکزي نيويورک .

هاليس نوشته بود : تو مرا خواهي شناخت از روي گل سرخي که بر کلاهم خواهم گذاشت .

بنابراين راس ساعت 7  " جان " به دنبال دختري مي گشت که قلبش را سخت دوست مي داشت اما چهره اش را هرگز نديده بود . ادامه ماجرا را از زبان خود جان بشنويد :
" زن جواني داشت به سمت من مي‌آمد, بلند قامت و خوش اندام, موهاي طلايي‌اش در حلقه‌هاي زيبا کنار گوش‌هاي ظريفش جمع شده بود , چشمان آبي رنگش به رنگ آبي گل ها بود , و در لباس سبز روشنش به بهاري مي مانست که جان گرفته باشد . من بي اراده به سمت او قدم برداشتم , کاملا بدون توجه به اين که او آن نشان گل سرخ را بر روي کلاهش ندارد . اندکي به او نزديک شدم . لب هايش با لبخند پرشوري از هم گشوده شد , اما به آهستگي گفت " ممکن است اجازه دهيد عبور کنم ؟ " بي‌اختيار يک قدم ديگر به او نزديک شدم ودر اين حال ميس هاليس را ديدم . تقريبا پشت سر آن دختر ايستاده بود زني حدودا 40 ساله با موهاي خاکستري رنگ که در زير کلاهش جمع شده بود . اندکي چاق بود و مچ پايش نسبتا کلفتش توي کفش هاي بدون پاشنه جا گرفته بودند

دختر سبز پوش از من دور مي شد , من احساس کردم که بر سر يک دوراهي قرارگرفته ام . از طرفي شوق وتمنايي عجيب مرا به سمت آن دختر سبز پوش فرا ميخواند و از سويي علاقه اي عميق به زني که روحش مرا به معناي واقعي کلمه مسحور کرده بود , به ماندن دعوتم مي کرد .

او آن جا ايستاده بود با صورت رنگ پريده و چروکيده اش که بسيار آرام و موقر به نظر مي رسيد وچشماني خاکستري و گرم که از مهرباني مي درخشيد . ديگر به خود ترديد راه ندادم . کتاب جلد چرمي آبي رنگي در دست داشتم که در واقع نشان معرفي من به حساب مي آمد , از همان لحظه فهميدم که ديگر عشقي در کار نخواهد بود , اما چيزي به دست آورده بودم که ارزشش حتي از عشق بيشتر بود , دوستي گرانبهايي که مي توانستم هميشه به آن افتخار کنم .

 به نشانه احترام و سلام خم شدم و کتاب را براي معرفي خود به سوي او دراز کردم . با اين .وجود وقتي شروع به صحبت کردم از تلخي ناشي از تاثري که در کلامم بود متحير شدم .

من " جان بلانکارد" هستم و شما هم بايد دوشيزه مي نل باشيد . از ملاقات شما بسيار خوشحالم . ممکن است دعوت مرا به شام بپذيريد؟ چهره آن زن با تبسمي شکيبا از هم گشوده شد و به آرامي گفت: فرزندم من اصلا متوجه نمي‌شوم! ولي آن خانم جوان که لباس سبز به تن داشت و هم اکنون از کنار ما گذشت از من خواست که اين گل سرخ را روي کلاهم بگذارم و گفت اگر شما مرا به شام دعوت کرديد بايد به شما بگويم که او در رستوران بزرگ آن طرف خيابان منتظر شماست . او گفت که اين فقط يک امتحان است !

تحسين هوش و ذکاوت ميس مي نل زياد سخت نيست !


طبيعت حقيقي يک قلب تنها زماني مشخص مي شود که به چيزي به ظاهر بدون جذابيت پاسخ بدهد .

۱۳۸۹ شهریور ۲۵, پنجشنبه

پاک کردن دوره ای لاگ های User Manager

یکی از امکانات خوب میکروتیک برای سازمان ها و شرکت ها با کاربر کم یا متوسط و نیازمند حسابداری اینترنت با امکانات محدودتر نسبت به نرم افزارهای مشابه حرفه ای User Manager می باشد که بر روی میکروتیک نصب می شود و نیازمند سیستم مجزا نمی باشد.
این نرم افزار خوب و گاها بسیار کارگشا در مواردی برای میکروتیک مشکلاتی ایجاد می کند که می بایست با نوشتن اسکریپت های خاص آن موضوع مشکلات را به حداقل رساند.
در این آموزش به یکی از این مشکلات که پر شدن هارد و اشغال شدن CPU به سبب حجم بالای لاگ های User Manager است می پردازیم.
در بسیاری موارد نیروهای پشتیبان برای پاسخگویی به کاربران و پیدا کردن مشکلات اهراز هویت و ... به لاگ های Authorisation & Authorisation & Accounting در User Manager نیازمند می باشند،در صورت فعال شدن این لاگ ها بعد از مدتی با زیاد شدن تعداد لاگ ها حجم هارد را تماما اشغال می کند و بار بر روی CPU را به شدت افزایش می دهد. 
مراحل انجام کار :
دستورات زیر را در ترمینال اجرا کنید:
  • ساخت اسکریپت
مطابق عکس بالا در Winbox به System>Scripts رفته و اسکریپتی به نام Rm_UM_log با منبع زیر ایجاد کنید.
:local Flag
:set Flag [/tool user-manager log find]
:if ([:len $Flag] > 0) do={/tool user-manager log print append file log;/tool user-manager log remove [/tool user-manager log find];}
  • نوشتن زمانبندی
مطابق عکس بالا زمانبدی را ایجاد کنید یا دستورات زیر را در ترمینال وارد کنید.
/system scheduler
add name="Rm-U-log" on-event="Rm_UM_log" start-date=Sep/15/2010 start-time=07:30:00 interval=7d comment="" disabled=no
 
در قسمت on-event اسم اسکریپت ایجاد شده می بایست وارد شود.
نکته :
حتما NTP Client را فعال کنید تا ساعت و تاریخ میکروتیک بعد از Reboot تغییر نکند.

---------------
پاورقی :
در صورت نیاز به حذف Session ها ،تمام مراحل مطابق با آموزش ذکر شده در بالا می باشد و فقط در قسمت ساخت اسکریپت از منبع زیر استفاده کنید :
:local Flag
:set Flag [/tool user-manager session find]
:if([:len $Flag]>0) do={/tool user-manager session print; /tool user-manager session remove [/tool user-manager session find];}
 

۱۳۸۹ شهریور ۲۳, سه‌شنبه

PostgreSQL server failed to start


امروز داشتم postgresql نصب می کردم که با خطای زیر مواجه شدم :
server2:~# /etc/init.d/postgresql-8.3 restart 
Restarting PostgreSQL 8.3 database server: mainThe PostgreSQL server failed to start. Please check the log output: 2010-09-14 15:30:26 IRDT LOG: could not load  root certificate file "root.crt": no SSL error reported 2010-09-14 15:30:26 IRDT DETAIL: Will not verify client certificates. 2010-09-14 15:30:26 IRDT FATAL: could not create shared memory segment: Invalid argument 2010-09-14 15:30:26 IRDT DETAIL: Failed system call was shmget(key=5432001, size=38207488, 03600). 2010-0  9-14 15:30:26 IRDT HINT: This error usually means that PostgreSQL's request for a shared memory segment exceeded your kernel's SHMMAX parameter. You can either reduce the request size or reconfigure the kernel with larger SHMMAX. To reduce the request size (currently 38207488 bytes), reduce PostgreSQL's shared_buffers parameter (currently 4096) and/or its max_connections parameter (currently 103).If the request size is already small, it's possible that it is less than ur kernel's SHMMIN parameter, in which case raising the request size or reconfiguring SHMMIN is called for. The PostgreSQL documentation contains more information about shared memory configuration. failed! failed!

راه حل :
echo "kernel.shmmax = 134217728" >> /etc/sysctl.conf
echo "kernel.shmall = 134217728" >> /etc/sysctl.conf
sysctl -p