۱۳۸۶ تیر ۹, شنبه

آموزش تصویری راه اندازی GRE tunnel بر روی روتر سیسکو

ciscogre

برای مشاهده تصویر در سایز واقعی روی آن کلیک کنید

برای مشاهده آموزش کلیک کنید

برای دانلود آموزش کلیک کنید

RouterA
Public IP: 217.219.50.100
Tunnel IP: 192.168.0.1
Private network: 192.168.1.0/24
IP on that private network: 192.168.1.1

RouterB
Public IP: 217.219.97.1
Tunnel IP: 192.168.0.2
Private network: 192.168.2.0/24
IP on that private network: 192.168.2.1

Config on RouterA :
interface Tunnel0
description connection to RouterB
ip address 192.168.0.1 255.255.255.0
tunnel source Serial 1/0
tunnel destination 217.219.97.1
tunnel mode gre ip

Config on RouterB :
interface Tunnel0
description connection to Linux RouterA
ip address 192.168.0.2 255.255.255.0
tunnel source Serial 1/0
tunnel destination 217.219.50.100
tunnel mode gre ip

Creating A Local Yum Repository-CentOS

برای فدورا و ردهت هم میتوان بهمین طریق عمل کرد
Create the Directories
mkdir -pv /var/www/html/centos/base

The Base Repository

Copy the RPMs from the CDs/DVD to /var/www/html/centos/base
Create the base repository headers
createrepo /var/www/html/centos/base

Yum Configuration
Edit yum.conf:
nano /etc/yum.repos.d/CentOS-Base.repo
[base]
name=CentOS-$releasever - Base
baseurl=http://192.168.*.*/centos/$releasever/os/$basearch/
gpgcheck=1
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-5
source 
http://www.trinix.be

آموزش تصویری تنظیم روتر سیسکو همچون یک سرور VPN-PPTP

احتمالا تا حالا به فکر استفاده از روترهای سیسکو به عنوان VPN سرور افتادین ولی بخاطر اینکه فکر میکردین حتما باید از Cisco VPN client استفاده کنید از انجام اون منصرف شدن...باید بگم که سیسکو هم این قابلیت رو داره که بصورت یک PPTP VPNسرور تنظیم بشه تا از VPN client پیش فرض ویندوز استفاده کنیم که همچنین نسخه های لینوکسی اون هم موجود است.
برای آنکه IOS روتر شما همچون یک VPNسرور عمل کند باید نسخه ای از IOS که DES یا 3DES را پشتیبانی میکند تهیه کنید.
این نسخه هایی هستند که قابلیت Encryption را دارند که همراه با PPTP برای استفاده از MSChap v1&2 الزامی هستند.
IOSهایی که از DES یا 3DES پشتیبانی میکنند در نام خود یک k8 یا k9 دارند و از این طریق قابل شناسایی هستند.

مراحل انجام کار :

PersianAdmins.com(config)# vpdn enable

Create a VPDN group configured to PPTP, just like the Microsoft VPN client will use, by default:

PersianAdmins.com(config)# vpdn-group reza

PersianAdmins.com(config-vpdn)# accept-dialin

PersianAdmins.com(config-vpdn)# protocol pptp

PersianAdmins.com(config-vpdn)# virtual-template 1

PersianAdmins.com(config-vpdn)# exit

Here, we will configure our interfaces to match the diagram. Naturally, your IP address configuration will vary:

PersianAdmins.com(config)# interface ethernet0/0

PersianAdmins.com(config-if)# ip address 192.168.0.5 255.255.255.0

PersianAdmins.com(config-if)# no shutdown

Next, create your virtual-template that will apply to the inbound VPN connections. This template references the e0/1 interface for its IP address. It also references a pool of IP addresses that will be handed out to VPN clients. Finally, it configures the PPP encryption and authentication mechanisms to match what the Microsoft VPN client defaults to:

PersianAdmins.com(config)# interface Virtual-Template1

PersianAdmins.com(config-if)# ip unnumbered FastEthernet0/0

PersianAdmins.com(config-if)# peer default ip address pool behroozi

PersianAdmins.com(config-if)# ppp encrypt mppe auto required

PersianAdmins.com(config-if)# ppp authentication ms-chap ms-chap-v2

Now, create the pool of IP addresses. This pool should not already be in use on the internal network you are connecting to:

Router(config)# ip local pool behroozi 10.0.0.1 10.0.0.100

After that, create a test user:

Router(config)# username test password 0 rezabehroozi
برای تنظیم کلاینت هم میتوانید این آموزش را مشاهده کنید یا مراحل زیر را همانند عکس ها طی کنید:
click Start | Control Panel | Network Connections. Click on New Connection Wizard
سپس :
تصویر 1


تصویر 2


تصویر 3



تصویر 4


تصویر 5


تصویر 6


تصویر 7


تصویر 8


تصویر 9


تصویر 10

۱۳۸۶ خرداد ۲۹, سه‌شنبه

Active FTP vs. Passive FTP

Active FTP

In active mode FTP the client connects from a random unprivileged port (N > 1024) to the FTP server's command port, port 21. Then, the client starts listening to port N+1 and sends the FTP command PORT N+1 to the FTP server. The server will then connect back to the client's specified data port from its local data port, which is port 20.

When drawn out, the connection appears as follows:

















Passive FTP

In passive mode FTP the client initiates both connections to the server, solving the problem of firewalls filtering the incoming data port connection to the client from the server. When opening an FTP connection, the client opens two random unprivileged ports locally (N > 1024 and N+1). The first port contacts the server on port 21, but instead of then issuing a PORTPASV command. The result of this is that the server then opens a random unprivileged port (P > 1024) and sends the PORT P command back to the client. The client then initiates the connection from port N+1 to port P on the server to transfer data.

When drawn, a passive mode FTP connection looks like this:

۱۳۸۶ خرداد ۱۷, پنجشنبه

تنظیمات اولیه شبکه در Redhat , Fedora , CentOS و توزیع های مبتنی بر آنها

بعضی از دوستان که آموزش قبلی مربوط به تنظیمات اولیه شبکه در دبین و هم خانواده هاش رو مشاهده کردن, از اینکه اسمی از خانواده ردهت نمیومده بود گلایه کردند و بهمین خاطر این آموزش رو برای اونها میزارم.
برای سرور اگر به ردهت علاقه دارد و همچنین میخواهید مجانی باشد , به نظر من بجای فدورا از CentOS استفاده کنید.
این آموزش به نحوه تنظیم DNS , Hostname و IP address میپردازد.
1-Hostname
برای تنظیم Hostnameهمانند زیر عمل کنید که Computername اسم مورد نظر شما میباشد :
echo computername > /etc/hostname
2-DNS
برای تنظیم DNS هم فایل etc/resolv.conf/ را مورد ویرایش قرار میدهیم :
echo 4.2.2.4 >> /etc/resolv.conf
بجای 4.2.2.4 آدرس یا اسم هر DNS سرور دیگری را میتوانید استفاده کنید و برای آدرس های بیشتر کافیست این دستور را هر بار با آدرس DNS سرور جدید بکار ببیرید.
3-IP address
بر خلاف دبین که تنظیمات همه کارت شبکه در یک فایل ذخیره میشود , در ردهت برای هر کارت شبکه میبایست یک فایل با نام ifcfg-ethX را در دایکتوری /etc/sysconfig/network-scripts/ ایجاد کنیم.
تنظیم کارت شبکه اول به نام Eth0 بطوریکه از آدرس Static استفاده کند:
nano /etc/sysconfig/network-scripts/ifcfg-eth0 #
DEVICE=eth0
BOOTPROTO=static
IPADDR=192.168.100.20
NETMASK=255.255.255.0
ONBOOT=yes
چند نمونه گزینه اختیاری :
HWADDR=00:30:48:56:A6:2E
TYPE=Ethernet
USERCTL=no
IPV6INIT=no
PEERDNS=yes
GATEWAY=192.168.0.1
نکته »
برای آنکه آدرس IP دومی به کارت شبکه اختصاص دهید کافیست مثلا برای eth0 این گونه عمل کنید :
nano /etc/sysconfig/network-scripts/ifcfg-eth0:1 #
تنظیمات هم همانند بالا میباشد.
تنطیم کارت شبکه دوم برای آنکه از DHCP سرور IP دریافت کند :
nano /etc/sysconfig/network-scripts/ifcfg-eth1 #
DEVICE=eth1
BOOTPROTO=dhcp
ONBOOT=yes
و در آخر سرویس مورد نظر را restart میکنیم :
etc/init.d/network restart/

برای تغییر آدرس IP بصورت موقت بدین گونه عمل میکنیم

ifconfig eth0 192.168.0.100 broadcast 192.168.0.255 netmask 255.255.255.0

و اگر میخواهیم این آدرس دوم کارت شبکه باشد :

ifconfig eth0:1 192.168.0.1 broadcast 192.168.0.255 netmask 255.255.255.0 up

توجه داشته باشید که این آدرس ها بعد از هر بار شروع مجدد سیستم از بین خواهند رفت.